import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^x\\/\\(x\\+\\d+\\)\\s*=\\s*\\(\\d+x\\)\\/\\d+$";
final String string = "x/(x+70) = (4x)/2\n\n"
+ "x/(x+7)=(4x)/2\n\n"
+ "x/(x+7) \n"
+ "= \n"
+ "(4x)/2\n\n"
+ "x/(x+7)=(4x)/28";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}