#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[01]{8}$)(?!(?:0*1){6,})[01]+$"
Local $sString = "01101101" & @CRLF & _
"01111100" & @CRLF & _
"10110011" & @CRLF & _
"01010101" & @CRLF & _
"00011111" & @CRLF & _
"11111000" & @CRLF & _
"00000000" & @CRLF & _
"101010100" & @CRLF & _
"101010100000000000000000000000000000000" & @CRLF & _
"" & @CRLF & _
"00111111" & @CRLF & _
"11111111" & @CRLF & _
"011111" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")