import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[01]{8}$)(?!(?:0*1){6,})[01]+$";
final String string = "01101101\n"
+ "01111100\n"
+ "10110011\n"
+ "01010101\n"
+ "00011111\n"
+ "11111000\n"
+ "00000000\n"
+ "101010100\n"
+ "101010100000000000000000000000000000000\n\n"
+ "00111111\n"
+ "11111111\n"
+ "011111\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}