$re = '/^(?=[01]{8}$)(?!(?:0*1){6,})[01]+$/m';
$str = '01101101
01111100
10110011
01010101
00011111
11111000
00000000
101010100
101010100000000000000000000000000000000
00111111
11111111
011111
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);