using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[01]{8}$)(?!(?:0*1){6,})[01]+$";
string input = @"01101101
01111100
10110011
01010101
00011111
11111000
00000000
101010100
101010100000000000000000000000000000000
00111111
11111111
011111
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}