re = /^(?=[01]{8}$)(?!(?:0*1){6,})[01]+$/m
str = '01101101
01111100
10110011
01010101
00011111
11111000
00000000
101010100
101010100000000000000000000000000000000
00111111
11111111
011111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end