#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*.(Helligkeit|Temp).*"
Local $sString = "Wetter.Helligkeit.Süd" & @CRLF & _
"Wetter.Bla.Hallo" & @CRLF & _
"Zimmer.Temp.Soll" & @CRLF & _
"Zimmer.Nix" & @CRLF & _
"Wetter.Temp" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")