import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*.(Helligkeit|Temp).*";
final String string = "Wetter.Helligkeit.Süd\n"
+ "Wetter.Bla.Hallo\n"
+ "Zimmer.Temp.Soll\n"
+ "Zimmer.Nix\n"
+ "Wetter.Temp\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}