using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*.(Helligkeit|Temp).*";
string input = @"Wetter.Helligkeit.Süd
Wetter.Bla.Hallo
Zimmer.Temp.Soll
Zimmer.Nix
Wetter.Temp
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}