$re = '/.*.(Helligkeit|Temp).*/';
$str = 'Wetter.Helligkeit.Süd
Wetter.Bla.Hallo
Zimmer.Temp.Soll
Zimmer.Nix
Wetter.Temp
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);