package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*.(Helligkeit|Temp).*`)
var str = `Wetter.Helligkeit.Süd
Wetter.Bla.Hallo
Zimmer.Temp.Soll
Zimmer.Nix
Wetter.Temp
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}