re = /.*.(Helligkeit|Temp).*/
str = 'Wetter.Helligkeit.Süd
Wetter.Bla.Hallo
Zimmer.Temp.Soll
Zimmer.Nix
Wetter.Temp
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end