#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=<w-block-content[\s\S]*?<span[\s\S]*?<div[\s\S]*?>)[\s\S]*?(?=<\/w-block-content>)"
Local $sString = "" & @CRLF & _
" <w-block-content id="A">" & @CRLF & _
" CONTENT OF #A" & @CRLF & _
" <span id="B">" & @CRLF & _
" CONTENT OF #B" & @CRLF & _
" <div id="C">" & @CRLF & _
" <p>CONTENT OF #C</p>" & @CRLF & _
" </div>" & @CRLF & _
" CONTENT OF #B" & @CRLF & _
" </span>" & @CRLF & _
" CONTENT OF #A" & @CRLF & _
" </w-block-content>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")