re = /(?<=<w-block-content[\s\S]*?<span[\s\S]*?<div[\s\S]*?>)[\s\S]*?(?=<\/w-block-content>)/
str = '
<w-block-content id="A">
CONTENT OF #A
<span id="B">
CONTENT OF #B
<div id="C">
<p>CONTENT OF #C</p>
</div>
CONTENT OF #B
</span>
CONTENT OF #A
</w-block-content>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end