using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<w-block-content[\s\S]*?<span[\s\S]*?<div[\s\S]*?>)[\s\S]*?(?=<\/w-block-content>)";
string input = @"
<w-block-content id=""A"">
CONTENT OF #A
<span id=""B"">
CONTENT OF #B
<div id=""C"">
<p>CONTENT OF #C</p>
</div>
CONTENT OF #B
</span>
CONTENT OF #A
</w-block-content>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}