use strict;
my $str = '
<w-block-content id="A">
CONTENT OF #A
<span id="B">
CONTENT OF #B
<div id="C">
<p>CONTENT OF #C</p>
</div>
CONTENT OF #B
</span>
CONTENT OF #A
</w-block-content>
';
my $regex = qr/(?<=<w-block-content[\s\S]*?<span[\s\S]*?<div[\s\S]*?>)[\s\S]*?(?=<\/w-block-content>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}