import Foundation
let pattern = #"(?<=<w-block-content[\s\S]*?<span[\s\S]*?<div[\s\S]*?>)[\s\S]*?(?=<\/w-block-content>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<w-block-content id="A">
CONTENT OF #A
<span id="B">
CONTENT OF #B
<div id="C">
<p>CONTENT OF #C</p>
</div>
CONTENT OF #B
</span>
CONTENT OF #A
</w-block-content>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)