const regex = /('[^']*?(?=secret|auth|key|password)[^']*':\s*')[^']*'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'[^\']*?(?=secret|auth|key|password)[^\']*\':\\s*\')[^\']*\'', 'g')
const str = `assdd ffdsfad 'result_secret_key': 'dfkfaj&^%2', 'auth_matrix': '213fsdf#', 'password': 'adsfa&&*!@#4' and 'app_auth': 'eff#@DS' dafsdsaf adfs adlsfjasdkjf `;
const subst = `\1****'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);