re = /('[^']*?(?=secret|auth|key|password)[^']*':\s*')[^']*'/
str = 'assdd ffdsfad \'result_secret_key\': \'dfkfaj&^%2\', \'auth_matrix\': \'213fsdf#\', \'password\': \'adsfa&&*!@#4\' and \'app_auth\': \'eff#@DS\' dafsdsaf adfs adlsfjasdkjf '
subst = '\\1****\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result