use strict;
my $str = 'assdd ffdsfad \'result_secret_key\': \'dfkfaj&^%2\', \'auth_matrix\': \'213fsdf#\', \'password\': \'adsfa&&*!@#4\' and \'app_auth\': \'eff#@DS\' dafsdsaf adfs adlsfjasdkjf ';
my $regex = qr/('[^']*?(?=secret|auth|key|password)[^']*':\s*')[^']*'/p;
my $subst = '\\1****\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";