# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"('[^']*?(?=secret|auth|key|password)[^']*':\s*')[^']*'"
test_str = "assdd ffdsfad 'result_secret_key': 'dfkfaj&^%2', 'auth_matrix': '213fsdf#', 'password': 'adsfa&&*!@#4' and 'app_auth': 'eff#@DS' dafsdsaf adfs adlsfjasdkjf "
subst = "\\1****'"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.