$re = '/(\'[^\']*?(?=secret|auth|key|password)[^\']*\':\s*\')[^\']*\'/';
$str = 'assdd ffdsfad \'result_secret_key\': \'dfkfaj&^%2\', \'auth_matrix\': \'213fsdf#\', \'password\': \'adsfa&&*!@#4\' and \'app_auth\': \'eff#@DS\' dafsdsaf adfs adlsfjasdkjf ';
$subst = "\1****'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;