import Foundation
let pattern = #"('[^']*?(?=secret|auth|key|password)[^']*':\s*')[^']*'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"assdd ffdsfad 'result_secret_key': 'dfkfaj&^%2', 'auth_matrix': '213fsdf#', 'password': 'adsfa&&*!@#4' and 'app_auth': 'eff#@DS' dafsdsaf adfs adlsfjasdkjf "##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1****'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)