package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(``([\'^\w]*)``)
var str = `<@961483653468439706> Text to remove, this text is useless, that's why i want it gone!
Type \`keep the letters and spaces\``
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}