$re = '/`([\'^\w]*)`/';
$str = '<@961483653468439706> Text to remove, this text is useless, that\'s why i want it gone!
Type `keep the letters and spaces`';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);