re = /`([\'^\w]*)`/
str = '<@961483653468439706> Text to remove, this text is useless, that\'s why i want it gone!
Type `keep the letters and spaces`'
# Print the match result
str.match(re) do |match|
puts match.to_s
end