const regex = new RegExp('`([\\\\'^\\w]*)`', '')
const str = `<@961483653468439706> Text to remove, this text is useless, that's why i want it gone!
Type \`keep the letters and spaces\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}