using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A(([r]\S+(?!\s+[wbpro]\S+)(\s+|\Z))|([b]\S+(?!\s+[wgo]\S+)(\s+|\Z))|([g]\S+(?!\s+[bprg]\S+)(\s+|\Z))|([w]\S+(?!\s+[wb]\S+)(\s+|\Z))|([op]\S+(?!\s+[wpgo]\S+)(\s+|\Z)))*\Z";
string input = @"white
red
green
orange
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}