re = /\A(([r]\S+(?!\s+[wbpro]\S+)(\s+|\Z))|([b]\S+(?!\s+[wgo]\S+)(\s+|\Z))|([g]\S+(?!\s+[bprg]\S+)(\s+|\Z))|([w]\S+(?!\s+[wb]\S+)(\s+|\Z))|([op]\S+(?!\s+[wpgo]\S+)(\s+|\Z)))*\Z/m
str = 'white
red
green
orange
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end