import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(([r]\\S+(?!\\s+[wbpro]\\S+)(\\s+|\\Z))|([b]\\S+(?!\\s+[wgo]\\S+)(\\s+|\\Z))|([g]\\S+(?!\\s+[bprg]\\S+)(\\s+|\\Z))|([w]\\S+(?!\\s+[wb]\\S+)(\\s+|\\Z))|([op]\\S+(?!\\s+[wpgo]\\S+)(\\s+|\\Z)))*\\Z";
final String string = "white\n"
+ "red\n"
+ "green\n"
+ "orange\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}