import Foundation
let pattern = #"\A(([r]\S+(?!\s+[wbpro]\S+)(\s+|\Z))|([b]\S+(?!\s+[wgo]\S+)(\s+|\Z))|([g]\S+(?!\s+[bprg]\S+)(\s+|\Z))|([w]\S+(?!\s+[wb]\S+)(\s+|\Z))|([op]\S+(?!\s+[wpgo]\S+)(\s+|\Z)))*\Z"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
white
red
green
orange
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)