const regex = /\A(([r]\S+(?!\s+[wbpro]\S+)(\s+|\Z))|([b]\S+(?!\s+[wgo]\S+)(\s+|\Z))|([g]\S+(?!\s+[bprg]\S+)(\s+|\Z))|([w]\S+(?!\s+[wb]\S+)(\s+|\Z))|([op]\S+(?!\s+[wpgo]\S+)(\s+|\Z)))*\Z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A(([r]\\S+(?!\\s+[wbpro]\\S+)(\\s+|\\Z))|([b]\\S+(?!\\s+[wgo]\\S+)(\\s+|\\Z))|([g]\\S+(?!\\s+[bprg]\\S+)(\\s+|\\Z))|([w]\\S+(?!\\s+[wb]\\S+)(\\s+|\\Z))|([op]\\S+(?!\\s+[wpgo]\\S+)(\\s+|\\Z)))*\\Z', 'gm')
const str = `white
red
green
orange
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}