use strict;
my $str = 'white
red
green
orange
';
my $regex = qr/\A(([r]\S+(?!\s+[wbpro]\S+)(\s+|\Z))|([b]\S+(?!\s+[wgo]\S+)(\s+|\Z))|([g]\S+(?!\s+[bprg]\S+)(\s+|\Z))|([w]\S+(?!\s+[wb]\S+)(\s+|\Z))|([op]\S+(?!\s+[wpgo]\S+)(\s+|\Z)))*\Z/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}