#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+?(?=( by .+?\.)|(\.))"
Local $sString = "Glass 849 by joseph stalin.png" & @CRLF & _
"Glass 24 by adolf hitler.jpg" & @CRLF & _
"Cloud 9 by C9Gaming.psd" & @CRLF & _
"154.png" & @CRLF & _
"286 by 666k.jpg" & @CRLF & _
"test123.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")