use strict;
my $str = 'Glass 849 by joseph stalin.png
Glass 24 by adolf hitler.jpg
Cloud 9 by C9Gaming.psd
154.png
286 by 666k.jpg
test123.jpg';
my $regex = qr/^.+?(?=( by .+?\.)|(\.))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}