re = /^.+?(?=( by .+?\.)|(\.))/m
str = 'Glass 849 by joseph stalin.png
Glass 24 by adolf hitler.jpg
Cloud 9 by C9Gaming.psd
154.png
286 by 666k.jpg
test123.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end