$re = '/^.+?(?=( by .+?\.)|(\.))/m';
$str = 'Glass 849 by joseph stalin.png
Glass 24 by adolf hitler.jpg
Cloud 9 by C9Gaming.psd
154.png
286 by 666k.jpg
test123.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);