using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+?(?=( by .+?\.)|(\.))";
string input = @"Glass 849 by joseph stalin.png
Glass 24 by adolf hitler.jpg
Cloud 9 by C9Gaming.psd
154.png
286 by 666k.jpg
test123.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}