import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+?(?=( by .+?\\.)|(\\.))";
final String string = "Glass 849 by joseph stalin.png\n"
+ "Glass 24 by adolf hitler.jpg\n"
+ "Cloud 9 by C9Gaming.psd\n"
+ "154.png\n"
+ "286 by 666k.jpg\n"
+ "test123.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}