#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<iframe[^>]*src=[\"|']([^'\"]+)[\"|'][^>]*>"
Local $sString = "<iframe src="http://flashx.tv/embed-76oom84mwi54-640x360.html" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="640" height="360"></iframe>" & @CRLF & _
"" & @CRLF & _
"<a href="http://fullpeliculas.com/mcfarland-usa/">" & @CRLF & _
"<div class="im">" & @CRLF & _
"<img src="http://fullpeliculas.com/wp-content/uploads/2014/11/McFarland-USA-150x150.jpg">" & @CRLF & _
"</div>" & @CRLF & _
"<p>" & @CRLF & _
"McFarland: Sin lĂmites</p></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")