const regex = /<iframe[^>]*src=[\"|']([^'\"]+)[\"|'][^>]*>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe[^>]*src=[\\"|\']([^\'\\"]+)[\\"|\'][^>]*>', 'i')
const str = `<iframe src="http://flashx.tv/embed-76oom84mwi54-640x360.html" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="640" height="360"></iframe>
<a href="http://fullpeliculas.com/mcfarland-usa/">
<div class="im">
<img src="http://fullpeliculas.com/wp-content/uploads/2014/11/McFarland-USA-150x150.jpg">
</div>
<p>
McFarland: Sin lĂmites</p></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}