using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe[^>]*src=[\""|']([^'\""]+)[\""|'][^>]*>";
string input = @"<iframe src=""http://flashx.tv/embed-76oom84mwi54-640x360.html"" frameborder=""0"" marginwidth=""0"" marginheight=""0"" scrolling=""no"" width=""640"" height=""360""></iframe>
<a href=""http://fullpeliculas.com/mcfarland-usa/"">
<div class=""im"">
<img src=""http://fullpeliculas.com/wp-content/uploads/2014/11/McFarland-USA-150x150.jpg"">
</div>
<p>
McFarland: Sin lĂmites</p></a>";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}