import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe[^>]*src=[\\\"|']([^'\\\"]+)[\\\"|'][^>]*>";
final String string = "<iframe src=\"http://flashx.tv/embed-76oom84mwi54-640x360.html\" frameborder=\"0\" marginwidth=\"0\" marginheight=\"0\" scrolling=\"no\" width=\"640\" height=\"360\"></iframe>\n\n"
+ "<a href=\"http://fullpeliculas.com/mcfarland-usa/\">\n"
+ "<div class=\"im\">\n"
+ "<img src=\"http://fullpeliculas.com/wp-content/uploads/2014/11/McFarland-USA-150x150.jpg\">\n"
+ "</div>\n"
+ "<p>\n"
+ "McFarland: Sin lĂmites</p></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}