#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\(\d{3}\)\s{1}\d{3}-\d{4})|(\d{3}\s{1}\d{3}\s\d{4})|(\d{3}-{1}\d{3}-\d{4})"
Local $sString = "#Valid phone numbers:" & @CRLF & _
"(123) 456-7890" & @CRLF & _
"987-654-3210" & @CRLF & _
"(555) 123-4567" & @CRLF & _
"123 456 7890" & @CRLF & _
"555 987 6543" & @CRLF & _
"" & @CRLF & _
"#Invalid phone numbers:" & @CRLF & _
"123-4567" & @CRLF & _
"(123) 456-789" & @CRLF & _
"987-654-321" & @CRLF & _
"(555) 123-45678" & @CRLF & _
"555-987-65432"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")