$re = '/(\(\d{3}\)\s{1}\d{3}-\d{4})|(\d{3}\s{1}\d{3}\s\d{4})|(\d{3}-{1}\d{3}-\d{4})/m';
$str = '#Valid phone numbers:
(123) 456-7890
987-654-3210
(555) 123-4567
123 456 7890
555 987 6543
#Invalid phone numbers:
123-4567
(123) 456-789
987-654-321
(555) 123-45678
555-987-65432';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);