import Foundation
let pattern = #"(\(\d{3}\)\s{1}\d{3}-\d{4})|(\d{3}\s{1}\d{3}\s\d{4})|(\d{3}-{1}\d{3}-\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#Valid phone numbers:
(123) 456-7890
987-654-3210
(555) 123-4567
123 456 7890
555 987 6543
#Invalid phone numbers:
123-4567
(123) 456-789
987-654-321
(555) 123-45678
555-987-65432
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)