// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\(\d{3}\)\s{1}\d{3}-\d{4})|(\d{3}\s{1}\d{3}\s\d{4})|(\d{3}-{1}\d{3}-\d{4})").unwrap();
let string = "#Valid phone numbers:
(123) 456-7890
987-654-3210
(555) 123-4567
123 456 7890
555 987 6543
#Invalid phone numbers:
123-4567
(123) 456-789
987-654-321
(555) 123-45678
555-987-65432";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}