import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(\\d{3}\\)\\s{1}\\d{3}-\\d{4})|(\\d{3}\\s{1}\\d{3}\\s\\d{4})|(\\d{3}-{1}\\d{3}-\\d{4})";
final String string = "#Valid phone numbers:\n"
+ "(123) 456-7890\n"
+ "987-654-3210\n"
+ "(555) 123-4567\n"
+ "123 456 7890\n"
+ "555 987 6543\n\n"
+ "#Invalid phone numbers:\n"
+ "123-4567\n"
+ "(123) 456-789\n"
+ "987-654-321\n"
+ "(555) 123-45678\n"
+ "555-987-65432";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}