import re
regex = re.compile(r"(\(\d{3}\)\s{1}\d{3}-\d{4})|(\d{3}\s{1}\d{3}\s\d{4})|(\d{3}-{1}\d{3}-\d{4})", flags=re.MULTILINE)
test_str = ("#Valid phone numbers:\n"
"(123) 456-7890\n"
"987-654-3210\n"
"(555) 123-4567\n"
"123 456 7890\n"
"555 987 6543\n\n"
"#Invalid phone numbers:\n"
"123-4567\n"
"(123) 456-789\n"
"987-654-321\n"
"(555) 123-45678\n"
"555-987-65432")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")