import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table(.(?!</table>))*";
final String string = "Remove this tag: <img src=\"path/to/image\">. \n"
+ "Also remove this tag: <img src=\"path/to/second/image\">. \n"
+ "But don't touch this <img src=\"cid:1259asdhasi\">.\n"
+ "<table>fgf</table>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}